平素よりロジメーターをご利用いただきありがとうございます。
本日3月17日(月)8時50分頃から9時30分頃まで発生していたタブレットでの登録が不安定になる事象について、原因の特定と対策が完了いたしましたのでご報告いたします。
【発生日時】
3月17日(月)8時50分頃から9時30分頃まで(現在は解消済み)
【事象】
ロジメーターへのアクセスが不安定になり、一部でタイムアウトが発生する。
【原因】
いくつかのマスタデータ取得処理において非効率なプログラム実装がなされていため、データ量増大により今までは問題なかった一部操作でサーバ負荷が上昇しました。
それが今回8:50頃という出勤登録が多い時間帯で発生してしまったため、タブレットでのデータ登録の応答が遅れてしまう(結果タイムアウトが発生してしまう)ことが頻発してしまいました。
【対応】
上記、マスタデータの取得処理にて非効率だった箇所を特定し、プログラムの改修を行いました。
これにより、システムの負荷が減少し通常稼働範囲内となりました。
【別の不具合について】
また、緊急で上記のメンテナンスを行ったため、一部不具合が混入してしまい
・タブレット設定画面でデータが表示されない
・各画面で管理グループ・荷主の表示順が変わる、または表示されなくなることにより、データが表示されない
事象が一時的に発生してしまいました。こちらも該当事象が発生したお客様よりご連絡をいただき、速やかに修正いたしました。
この度は皆様に大変なご迷惑をお掛けいたしまして、申し訳ございません。再発の防止に努めてまいります。
今後とも弊社サービスをよろしくお願いいたします。