ロジメーターをご利用の皆様
平素よりロジメーターをご利用いただきありがとうございます。
昨日1月29日(月)17時50分〜18時50分頃の間、一部ユーザーの皆様において、ロジメーターへの接続に時間がかかりタイムアウトする状況が発生しており、同19時19分に原因である作業csv作成機能を一時停止することでに解消いたしました。
その後、作業csv作成機能は1月30日(火)9時57分に再開いたしました。
この度は一部ユーザー様においてロジメーターへの接続障害が発生したことにより、サービス利用に影響が出てしまい申し訳ございませんでした。
今回発生した事象について原因究明と対応策を講じましたので、以下の通り報告いたします。
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【障害発生の時間帯】
2024年1月29日(月) 17時50分から1月29日(月) 18時50分頃まで
【対象者】
ロジメーターの一部ユーザー様
【現象】
ロジメーターへの接続時の応答時間が長くなり、タイムアウトが発生。
【原因】
作業csv作成開始時に行う処理の一部に、特定の条件下でサーバに高負荷がかかってしまうバグが混入していました。
1ユーザーの操作のみではサーバ全体に影響を与えるものではなく、今回、複数のユーザーによる操作のタイミングにより
上記高負荷が同時に複数発生し、計画していた負荷の許容量を超えてサーバ全体に波及しました。
【対応】
同処理プログラムの修正を完了し、すでにロジメーターへ適用いたしました。
【経緯】
1月29日(月) 17時50分頃、当該事象が発生し、同18時頃障害を確認いたしました。
複数要因が重なり、作業CSV作成機能がスタックしていることが判明し、作業CSV作成機能を一度停止することによって、
作業CSV作成機能を除く全機能の復旧が完了しました。
その後、作業CSV作成機能の修正プログラムを適用し、現時点で全機能が復旧しております。
・1月29日(月) 17時50分:障害が発生
・1月29日(月) 18時00分:障害発生を確認
・1月29日(月) 19時19分:作業CSVの作成以外の機能の復旧
・1月30日(火) 9時57分:作業CSVの作成機能の復旧
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この度は、皆様に多大なるご迷惑とご心配をおかけし改めてお詫び申し上げます。
再発防止に弊社一同努めてまいりますので、これまでと変わらぬご愛顧のほどどうぞよろしくお願いいたします。